gentle-giant

Problema visualizzazione con Chrome

Se anche voi, come me, negli ultimi 3-4 giorni vi siete imbattuti in problemi di visualizzazione dei vostri siti e-commerce realizzati con woocommercce, vi dico subito che non è il caso di agitarsi troppo, ammesso che non abbiate già scoperto l’inghippo voi stessi e stiate festeggiando con un mojito a bordo piscina.

Il fatto è che questa volta l’ “infallibile” Google ha rilasciato una nuova versione di Chrome (n. 44) che presenta una possibile incompatibilità con il noto plugin Woocommerce. In pratica, su piattaforme WordPress con plugin Woocommerce, Chrome tende a settare automaticamente il protocollo HTTPS, invece del classico HTTP.

Ma poiché raramente il vostro sito, a meno che non si tratti di un grande e importante progetto, farà uso del supporto SSL e HTTPS, il browser cercando di aprire una pagina del sito darà errore (sito non raggiungibile). Ovviamente il problema si verifica soltanto con Chrome ma poiché esso è attualmente il browser più utilizzato al mondo è bene risolvere il problema. Come fare?

La soluzione più semplice è farlo attraverso il plugin (prontamente rilasciato) Chrome HTTPS bug fix for woocommerce, che non fa altro che dire al browser che il sito  in questione è ospitato in un server http e non https.

In attesa della nuova versione del browser di Mountain View, mettiamoci una toppa e andiamo avanti, consapevoli che anche i giganti possono sbagliare.

No Comments

Post a Comment